System slow

Incident Report for GEM SUITE

Resolved

This incident has been resolved.
Posted Jul 28, 2026 - 10:34 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2026 - 09:32 EDT

Investigating

We are currently investigating this issue.
Posted Jul 21, 2026 - 09:18 EDT
This incident affected: External (Twilio (SMS), AWS Databases, AWS Servers, Cloudflare, GitHub, New Relic, OpenVPN, Plaid, Redis, Sentry, Shopify, Stripe, Vonage (SMS)), GEM-SUITE (GEM-SMS, GEM-LINK, GEM-API, GEM-PLEX, GEM-TMS, GEM-BOOKS, GEM-CAR), and GEM-SUITE.